Angband Forums

Angband Forums (
-   Sil (
-   -   Sil-Q final beta release before 1.5.0 (

Quirk October 9, 2021 00:32


Originally Posted by bron (Post 155690)
Also - is the 900' forge now not a guaranteed thing? I've had a couple of runs that didn't have a forge when I entered 900' for the first time. OTOH, I have been consistently finding a forge at 300'. What's the truth about guaranteed forges in the latest version?

They got pushed earlier, to 100', 300' and 500'. This sets smiths up early, but after 500' they're falling back on Delvings, Revelations and exploration to find more.

smbhax October 11, 2021 07:17

Thanks for working on the game! : D

I'm a total newbie and all I've managed to find are some small interface and documentation issues that are no doubt old and known. Here they are just in case:

- Tutorial - Gauntlets note: says "penalty of -1 to your attacks" instead of "penalty of -1 to your accuracy"


The note on the (-1) [+0, 1d1] Gauntlets in the tutorial says "this means that they give a penalty of -1 to your attacks..." It goes on to say "armour and weapons in Sil come with trade-offs between attack (chance of hitting; damage) and defence (chance of evading hits; damage reduction)."

Because it says "penalty of -1 to your attacks" rather than "to your accuracy," and later says "attack (chance of hitting; damage)," I got confused and thought that by "attacks" it meant that the "(-1)" stat for the gauntlets meant they give -1 to both accuracy and damage.

The 1.5.0-beta2.pdf manual in the root directory, under Combat - Weapons and Armour, on the other hand, calls a (-1) on a piece of armor "a penalty to accuracy." I'm guessing this is the correct statement, and that the tutorial should say "accuracy" instead of "attacks" when talking about the (-1) on the gauntlets.

- Tutorial - Shortsword note: "that it is bears an enchantment" typo


The note about the shortsword in the tutorial says "indicating to the perceptive player that it is bears an enchantment against orcs." The "is" is superfluous and confusing, and should be removed.

- Tutorial traps note: "can be disarmed while holding down Control while attempting to move into it" inaccurate if "hjkl" move keys option is on


The note in the tutorial about traps says "like most traps, it can be disarmed by holding down Control while attempting to move into it..." However, if the player has the "Move with hjkl etc" Interface Option set, and tries to move with them while holding Control, the game will not execute a trap disarm function, but will instead execute the "underlying key" for whichever hjkl key you pressed--and the trap will not be disarmed.

Perhaps the note could explain that with hjkl keys on, the user can instead use the / key followed by a direction to disarm traps. (The old D key also works.)

- Skills menu: ESC or other key acts like Enter (confirm) if alphabetic shortcut key used to select ability


Since the xjkl keys don't work at all for navigating list menu screens such as the Skills menu, I resorted to browsing through ability descriptions in the Skills screen by picking skills and abilities directly via hitting the key corresponding to their "x)" alphabetic key label. This seems to cause a minor bug to occur once you've selected an ability that way, however: at that point, hitting ESC to back out acts as though you hit Enter to learn the ability, bringing up the "Are you sure you wish to gain this ability? [y/n]" confirmation prompt.

For instance:
1) From gameplay, hit Tab to bring up the Skills menu
2) On the Skills menu screen, press a to select the Melee skill
3) Press d to select the Polearm Mastery ability
4) Press the ESC key
-- Instead of backing you out of the Ability list, the "Are you sure you wish to gain this ability [y/n]?" prompt appears, as if you had hit Enter instead of ESC.

I found this also happened if I hit the p key instead of ESC; those were just the two keys I tried.

- Skills menu: available menu navigation keys not shown

Some menu screens, such as the Character Creation screens, list the navigation keys available for those screens at screen bottom. The Skills menu screen, however, does not tell the user what keys to use--so the user may not immediately know they learn a skill by selecting it with various navigation keys and finally hitting Enter, for instance.

- Help menu (mouse): Selecting "Contents" causes a "Cannot find help file" warning window to appear


When I selected "Help--Contents" from the game's top mouse menu, a window titled "Warning" appeared in the middle of the screen, saying "Cannot find help file: C:\Program Files\Sil-Q\lib\xtra\help\angband.hlp"--that was my correct directory for the game, but no "help" subfolder exists under "lib\xtra" in my fresh installation of 1.5.0-beta2.

There is a "tutorial" file in "lib\xtra," although I don't know how to open it so I can't tell if that's what was intended. I tried giving it a ".hlp" extension and then opening it, but this opened a Microsoft Support page saying "The Windows Help program is not supported in Windows 10, Windows Server 2012 or later versions of Windows Server. The Windows Help program is available for Windows Vista, 7, 8 and 8.1 only. Microsoft strongly recommends that software developers discontinue using the Windows Help application."

- Game references/files for "the manual" are unclear

Multiple confusing documentation issues regarding "the manual":

a) I encountered multiple recommendations by the game text--I think mostly in the tutorial, for instance in the note at the end of the basic part of the tutorial ("You now know more than enough..."; Video: ) --to read "the manual" for more information about the game's functions. It wasn't quite clear to me what exactly was meant by "the manual," although perhaps I missed some more specific direction given at some point.

I was unable to find a "manual" in the game's menus.

b) There are two pdf files with "manual" in their name in the extracted game's "lib\docs" folder: "Sil 1.3 Manual.pdf" (438 KB) and "Sil-Q 1.4.2 Manual.pdf" (4.28 MB). Judging from those titles, these are versions of Sil/Sil-Q manuals, but out of date ones. Possibly they should be removed to avoid confusion. Removing them would also save file space: the 1.4.2 manual alone accounts for about half of the game's total installation size.

c) There is a "Sil-Q v1.5.0-beta2.pdf" file (823 KB) in the game's root directory. This appears to be the actual, current manual. As such, it should have "manual" or something similar in its file name.

Since users may simply extract later Sil-Q releases into their existing installation folder, perhaps the manual should keep the same file name and location from version to version, ie "silq_manual.pdf," so that it will be overwritten by later versions, preventing further obsolete manuals from accumulating in the game's installation folders as time goes on.

- Manual: "dangerous place to tally" typo

In Sil-Q v1.5.0-beta2.pdf, in a paragraph discussing overuse of stairways, the text reads "making staircases a dangerous place to tally, say, while healing..."

"Tally" doesn't make sense in that context; probably "dally" was intended.

- Manual: "artefact" spelling differs from "artifact" spelling in game

Throughout Sil-Q v1.5.0-beta2.pdf, the spelling "artefact" is used when speaking of a particularly powerful type of item. The game, however, consistently spells this item type with an i rather than an e: "artifact"--in the Skills--Abilities--Jeweller section of the Skills screen, for instance.

Well, sorry for the cascade of minor things there. ^_^ I've been having a great deal of fun with the game so far and am looking forward to playing it more. : )

Quirk October 11, 2021 09:00


Originally Posted by smbhax (Post 155730)
Well, sorry for the cascade of minor things there. ^_^ I've been having a great deal of fun with the game so far and am looking forward to playing it more. : )

Thank you very much for reporting all these issues, it's reports like these that make the game better. Hope you continue to enjoy your play!

smbhax October 11, 2021 18:21


Originally Posted by Quirk (Post 155731)
Thank you very much for reporting all these issues, it's reports like these that make the game better. Hope you continue to enjoy your play!

Thanks! : )

In trying to map keys for Use and Look so I don't have to press Ctrl with u and l all the time under the hjkl key scheme, I stumbled across a few more documentation-related things:

Macros and keymaps are not documented

They're pretty confusing. I finally managed to get myself working alternate keys for u and l with keymaps--so I don't have to use Ctrl with them all the time under the hjkl keys option--but it took a long time: I had trouble with finding keys to put them on; trouble with trying them as macros at first and finding that makes whatever keys I put them on unusable for anything else in the game, like typing those letters in a character name; trouble with figuring out how to save and load them properly; and trouble with figuring out that keymaps have to refer to the "underlying" key function, so for Use in hjkl I needed to specify "u" rather than "^u". And I guess I still need to load a .prf file to get them into any new character I make; I couldn't find a way to have them--or my preferred Options settings--on as defaults for new characters.

; (repeatable direction?) key is undocumented

Pressing ; prompts you to input a direction to "repeat," or something, but it doesn't do continuous movement like . does, and it is not listed in the ? command list. I couldn't figure out what it does. (I found it when looking for a handy key to use for my keymap--for now I've mapped Use to it. : p)

[ (Monsters you can see) and ] (Items you can see) are undocumented

Stumbled across [ and ] when looking for potential keys for keymaps, and I'm glad I did! They aren't listed in the ? command list, yet they seem incredibly useful; Angband's "Item list" subwindow is one of two things vanilla has that I was really wishing this game had--the other being a persistent levels option--but ] at least goes a little way toward that. Both keys seems like something new players could benefit from knowing about.

(I would still really like to have an Item List subwindow though. ^_^)

\ and - are not listed in the ? command list

\ (brings up a seemingly redundant command prompt) and - (described on the Skills screen under Fletchery) are not listed in the ? command list.


HugoVirtuoso October 11, 2021 23:05

More examples to supplement smbhax observations:

At the character sheet screen:
Pressing Enter/Return key exits that screen. Perhaps there should be extra message to indicate this is as intended or make Enter/Return not do that

Pressing Spacebar bring up the in-game log? Was this intended? Again, adding another statement on spacebar usage would be useful

When offering an item to an alert Thrall:
Although the Esc key cancels the offer, the prompt says "Esc" by itself. It should say "Press 'Esc' to cancel offer." I know this is self-explanatory but I want this to be more obvious to other players who are new to this

bron October 13, 2021 20:41

I ran across a bug:

I Smith a War Hammer of Crushing (-1,4d3) by reducing the "special" bonus to zero, i.e. it now increases strength by +0. All good. However, if I wield the Hammer, and then exit and restart the game, the Hammer is magically transformed to be +1 to strength, rather than +0.

Quirk October 14, 2021 11:51


Originally Posted by bron (Post 155767)
I ran across a bug:

I Smith a War Hammer of Crushing (-1,4d3) by reducing the "special" bonus to zero, i.e. it now increases strength by +0. All good. However, if I wield the Hammer, and then exit and restart the game, the Hammer is magically transformed to be +1 to strength, rather than +0.

Have replicated this and will look into it. Free time has been at a premium lately, hope to get more over the weekend.

Infinitum October 16, 2021 10:31

I know it was changed a few versions ago, but the fact that shafts never crumble on the ascent trivializes it. Scum until you see the next exit. Egress. Might be needed due to how deadly V is to sneakers right now, idk.

smbhax October 16, 2021 19:45

- Subwindow draw order reverses after task switch
- Subwindow title bars don't obey Windows "Dark" color setting

This is just a minor aesthetic annoyance and possibly not even something the game's window manager can control, but in the Windows version, which seems to have a hard-coded order of overlap in which the subwindows are initially loaded, that subwindow draw order is reversed once you task switch away from the game and back to it again. This makes it impossible to keep the subwindows in a fixed order of overlap.

Combined with the title bars of subwindows staying a bright color even when the Windows "Color" setting is changed to "Dark," it means the player can't quite keep the subwindows rearranged to hide those very bright title bars at all times. =p

For instance:

- Place the Equipment subwindow overlapping the Inventory subwindow
- Place the Messages subwindow overlapping both Equipment and Inventory
- Save and quit Sil-Q
- Start Sil-Q back up and reload your character
-- Inventory is now overlapping Equipment, and both are overlapping Messages
- Task-switch to a different program, then back to Sil-Q
-- Equipment is back to overlapping Inventory, and both are back to overlapping Messages

This isn't a huge problem, but it leads to a minor inconvenience if you're like me and have your subwindows arranged super-obsessively to hide the glaringly bright title bars of the lower subwindows (I have Windows 10 set to Dark color but the game's window title bars don't seem to obey that Windows setting; also, the title bars just take up screen space = p), like so

Screenshot: before task switch

where, specifically, I've got the Inventory subwindow overlapping the top of the Equipment window below it, to hide the Equipment subwindow's title bar--and the game saves and restores perfectly with this arrangement. But once I Alt+Tab to task switch to another Windows program/window, then Alt+Tab back to Sil-Q, I find that the Inventory window has pushed to the back, so the Equipment subwindow's title bar is now showing over it:

Screenshot: after task switch

Clicking on the Inventory subwindow hides the Equipment subwindow title bar again, but this has to be re-done after every task switch if you're obsessed about keeping those bright title bars from glaring at you, like I am. ; )

Surprisingly, if you use ^e to swap the contents of the Equipment and Inventory subwindows, and rearrange them to swap their window layout positions, the Equipment window, now functioning as Inventory, is now the one that moves to the back after task switching.

If I swap the positions of the Inventory and Equipment subwindows, and have the bottom of Equipment overlapping the title bar of Inventory, this avoids the problem of the Equipment title bar showing after task switching; however, when starting the game, Inventory is initially drawing above Equipment, requiring a single click in Equipment to bring it to the front and hide Inventory's title bar. But Equipment then stays above Inventory through task switches, so that arrangement is usually better for me than having to click to hide Equipment's title bar after each task switch when they're in the reversed positions.

So yes I am apparently complaining about a minor aesthetic problem triggered only by my obnoxiously obsessive window arrangement habit, and which I can work around with a single mouse click or dual task switch after starting the game. ^_^

Quirk October 17, 2021 15:53

Thanks again for the bug reports, bron.

Have fixed the returning strength value, I think. I think it was actually a bug on all ego items with 0 pval, so it works also for armour.

The arrows bug was harder to replicate. I have managed it but it needs somewhat specific circumstances. You need the first slot to be below 99 arrows so it refills, but picking up arrows usually adds them to the first slot. If the second slot has 99 arrows, the bug doesn't appear to show itself. Once you manage to create initial conditions with less than 99 arrows of the same type across two quivers, you will find that taking off the arrows doesn't take them off but adds them to the first quiver instead. Have fixed this on my master branch also.

All times are GMT +1. The time now is 10:41.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.