Angband Forums

Angband Forums (
-   Variants (
-   -   RePosBand: play as a monster in Angbad 3.2 (

pampl January 13, 2011 12:16

I couldn't sleep so I worked on 0.6.3 instead, and it'll be out in time for the weekend. Quick start is fixed but it means savefiles aren't compatible so delay upgrading until you've died. Now spiders can spin webs, innate melee doesn't spam 2x as much feedback as it should, and other stuff I'll add as I remember (edit: randarts no longer break racial artifacts)


Originally Posted by AnonymousHero (Post 46832)
It should be just "configure". (Only exists after running the file.)

On second thought it might be better to avoid including it in the repository direct and instead providing a source download for each version (with "configure" included).

I don't have any "configure" file.. the only files I have without extensions are the makefiles, install-sh, run-tests, and HEADER. I've never run the file unless make runs it automatically :confused:

Originally Posted by Arjen (Post 46835)
I've discovered something weird. When i was clearing out an undead pit, i noticed my auto-destroy was reset. I wasn't destroying anything anymore. And in the past destroyed objects were spawned back in the level, psuedo-ided or even fully ided. So i went and put everything back in the auto-destroy and continued. Now i just cleared a demon pit. Same thing occurs. I put some spellbooks in the autodestroy and suddenly they are back on the ground with a lot of other stuff. And now i can't even put them back in auto-destroy or even just destroy them at all! So now i have to literally throw away stuff i don't want.

I have no idea what triggered this, i only know it started both times when i was killed a lot of monsters who drop a lot of items.

The squelcher doesn't destroy stuff, it just drops it then ignores it. There's a bug from V that your quality squelch settings get reset every time you close the game, but that shouldn't effect spellbooks.. can you attach a savefile to your post?

Posting this here so other people can get their 2c in as well...

Originally Posted by Arjen
The amount of equipmentslots is insane now. Got 11 amulets and 11 helmets. Even without randarts i think it too much. Just think about it. You can wield a:

- amulet of resistance
- amulet of trickery
- amulet of devotion
- amulet of weapmastery
And another 7 amulets

Same with helmets:
- of magi
- of might
- of lordliness
- of seeing
- of telepathy
- Gondor
- Dor-Lim
- Golim
- Hammerhand
- and another one

It would still be pretty overpower
But with randarts it's even more insane :) Got 3 immunities, 30+ speed, high stats, all resses, several melee bonusses, several ESP sources and 444 AC.

Even with all those you're still effectively a warrior who can't use a bow and is only doing 1/2 as much damage as a non-monster warrior (4 attacks * (20 base + 100 bonus) vs ~1000 damage per round). Now, I can definitely see how AC could get too high, and I'm willing to implement a diminishing returns formula on ACs over 150 or 200 (it'll just be a quick hack fix if AC is going to be changed in 3.3) but the marginal value of the non-AC bonuses from additional helmet/amulet slots once you already have ~4 is pretty low. By the time you've filled all those slots, it's the late late late end game and you'd have beaten Morgoth already if you were a demihuman.

If hydras are more powerful than their XP modifier indicates, I'm willing to increase it or even slightly reduce their stats, but I'm really reluctant to change their slots, especially their head/neck slots.

Arjen January 13, 2011 12:28

1 Attachment(s)
If it works this post must have the savefile?

pampl January 13, 2011 16:04


Originally Posted by Arjen (Post 46844)
If it works this post must have the savefile?

I can't figure out what happened with the spellbooks but have you tried pressing shift+K? I didn't know about it before looking at your savefile but it apparently turns the quality squelcher on and off.

Arjen January 13, 2011 16:56

shft+k i never used that command. What does it do? I use k for destroying stuff.

relic January 13, 2011 22:00


Originally Posted by pampl (Post 46792)
Good news for Mac users, Nick has compiled an OSX version.

I am confused. :confused:
Why is it called reposband-3.2.0? Is it compiled on the 0.6 source? Or 0.6.1?

Nick January 13, 2011 23:23


Originally Posted by relic (Post 46863)
I am confused. :confused:
Why is it called reposband-3.2.0? Is it compiled on the 0.6 source? Or 0.6.1?

It's a fairly sloppy job on my part - I haven't gone and checked stuff like version numbers. It's actually based on 0.6.2.

pampl January 14, 2011 01:45


Originally Posted by Arjen (Post 46853)
shft+k i never used that command. What does it do? I use k for destroying stuff.

Shift+k lets you see all the objects you've squelched with k. Pressing shift+k again should hide them all again, hopefully.

I decided that the oddball race I'd be adding is beholders. Spectators, gauths, beholders, then maybe a choice between undead beholders and beholder mothers. They can wear rings on their eyestalks and wrap cloaks around their heads but no other equipment (besides maybe a hat). In exchange they get powerful offensive magic. They'll probably be a challenge race, but that's OK.

Arjen January 14, 2011 09:04

Already like em!

Psi January 14, 2011 10:03


Originally Posted by pampl (Post 46871)
...but no other equipment (besides maybe a hat).

Well that's just shattered the fearsome image I had of those 'e's. Now I see a comedy eyeball with a stetson.

Nick January 14, 2011 10:46


Originally Posted by Psi (Post 46886)
Now I see a comedy eyeball with a stetson.

Good lookin' crowd tonight, great to see you all :)

All times are GMT +1. The time now is 22:56.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.